Not working as expected: Filter > Date > Today

It appears that the “is equal to Today” filter for a “Date” field does not function as expected. I have a list with due dates and I am able to filter on “Date is not empty” but get an empty list back when I filter on “Date is Today”, even though I have items with the same date value as today for that date field. Upon further investigation I also noticed that I was able to get today’s items back when I set the filter equal to tomorrow’s date. See below for visual walk through:

1 Like

@smiklakhani I believe there is a minor bug in Infinity’s Date attribute. What’s happening is that there are date and time attributes combined in this one “Date” attribute. If you are having this problem, here is how to fix it.

  1. Go to a Table View and edit this Date column.

  2. Toggle on the “Include a time field” and save. You will now see times after your selected dates.

  3. Select a time like 12:01AM or my random 01:03AM :stuck_out_tongue: , something that is the beginning of the day.

  4. Your today and equal filter should work for today’s tasks.

If you want to break this again, change the time to a later time (something beyond 4 hours out) and the task will no longer show in the filtered results.

Problem: When we select a new date, there is a timestamp that is created automatically. Below is making a new task not too long ago and assigning a date, I did not place in the time.

If I’m right and we forward to April 11th, I would not see my task until I’m within 4 hours of that timestamp when using the filter.

I believe that when we filter based on “today,” Infinity is looking at past and current times and will not include a task that is in the same-day but has a much later timestamp. Not sure if this is by design. If my timestamp is beyond 4 hours (my time, Pacific Time), then this task will not be shown when I filter for Today or Equals + Today’s Date.

@coa Hope you can confirm if this is a bug or by design…


@veronica, thanks for getting back to me with your findings! Based on your findings, I believe the main thing that needs to be done is that timezone complexities need to be accounted for. 9pm on April 4th for me (MDT timezone), is actually 3am on April 5th in terms of GMT (which I’m guessing the system may be using), which explains why those tasks that I had marked as being due on the 4th, were showing up under the 5th. Assuming the system stores everything in GMT, I guess “Today” needs to be viewed in the context of the user’s timezone, since “Today” may mean one thing to someone in the Philippines and another thing to someone in the United States.


@smiklakhani Yes. Hopefully, it helped you with your immediate issue. And sorry, I should have made it much more clear that the context of my findings is based on my PDT timezone. :smiley:

A user’s timezone is something that has to be accounted for. Your topic actually had me going through my profile to try to find something related to time or location… didn’t find anything. It would be good to have an account level setting as a default timezone (where every date is based on that), but maybe a case could be made for time settings at the workspace/board level too? I haven’t thought through the logistics of this yet.

1 Like

Hey @smiklakhani, @veronica!

You’re right guys: It is a bug. I’ve just talked to our team, and they should start fixing that today.

BTW. @veronica we are amazed by your resourcefulness. It’s awesome how you managed to figure out this on your own!

We’re going to work on improving this. We haven’t really done this on purpose by design, but is rather a bug :slight_smile:

Also: including a timezone for each account could be a good thing to do.

Guys – Thank you very much for this topic. We are amazed!

1 Like

@coa I’m glad that this wasn’t by design. Haha. Also, glad that @smiklakhani reported this because I probably would have never noticed it otherwise.

Please extend my thanks to the team for working on a fix so quickly.


I’m still having this issue - I could have sworn it was fixed.

Tasks with the same Date attribute don’t all show when filtering by Today/This Week.

@coa any update on this? Did an update break it, or is it still being worked on?

Hi @richardjohnpaul, it was fixed but it might have appeared again due to some update. On my end, it seems to be working fine, but it could be happening in specific conditions. Could you give me a bit more details on when it happens?

I’ll try to recount what happened.

I started with a list of 9 tasks created on Tuesday - the 9th of last week.

I set all of their Due Dates to July 12th or 13th (Friday + Saturday).

I added a new list view, set up a filter for Due Date to display “This Week” - only 5 of 9 tasks show up.

I get through my task list on Saturday and think I’m all done - but then I check the unfiltered list and see there were 4 tasks I had not completed - they were created alongside the other tasks and given a similar Date but for some reason no matter what I did they refused to show up in the filtered list for “This Week”.

I could get them to show if I set the date for the next week (or further) and then expanded the filtered date range to Month or a custom range - but Today/This Week wouldn’t show even if the dates were Today/This Week. This might be important? It could have something to do with the filters and not the Date attribute?

I also have a “Completed” filter for the checkbox and a sort by Date - removing either didn’t help.

The board I’m using was created a very long time ago - attributes as well. Maybe this has something to do with it?

I just tried to replicate this with the tasks that weren’t showing and it seems to be fixed? I also tried to replicate it with a new folder in the same board and all tasks are showing correctly.

This issue has come up a few times for me in the past couple months and caused some minor headaches over thinking I’m done with something when I’m not. I know it was supposed to get fixed and I thought it was, but I ran into it again last week.

I’ll keep an eye out for it again and try to keep track of what might be happening - if it happens again.

Thank you for the detailed explanation, @richardjohnpaul, I appreciate it. I can see how this could cause a headache, it’s definitely something that can’t be happening.

The problem now is that it seems to be happening with tasks created in a board created some time ago. If I understood you correctly, now that you try to filter them it’s fixed? – “I just tried to replicate this with the tasks that weren’t showing and it seems to be fixed?”

We’ll definitely look into it. It seems to me that it’s a filter issue, not date issue. But hopefully, it doesn’t happen again.

Please let me know if you notice it happening again. It’s best to get in touch with Boka in support and she’ll get on it as soon as she can. Thank you!

This has happened again.

I have a task I had created 22 days ago with a due date of Jul 16th - it is showing in my Today view.

I just created a new task a moment ago and set the due date to Jul 16th and it was filtered out of my Today view once I finished editing (system notified me as such with the red border/message).

At this point in my Today view only one task is showing (the task created 22 days ago) yet both tasks have date attributes set to Jul. 16th.

When I change the task that isn’t showing’s date to Jul 15th it shows up in my Today view. This also works on task creation.

So my Today filter is showing the task from 22 days ago due Jul 16th as well as a task I just created a few moments ago with a date attribute of Jul 15th, despite the filter being set to “Today”.

Very odd!

This has carried over to today now.

I’ve updated both tasks I mentioned before - the older task’s due date is the 17th and it’s showing up for Today.

The newer task says it was created Jul. 17th, in the activity log it was created 6 hours ago. 6 hours ago in my time zone was still Jul. 16th.

I hope that sheds a little more light on the issue.

It seems like we need to be able to set timezones for our accounts and have the system work off of those.

Hi @richardjohnpaul, this definitely sheds more light on the problem. This seems to be the issue with time zones. But it’s still very strange that it’s behaving in a different way with new and old tasks. Thank you for a detailed explanation. We’ll make sure to look into this as soon as possible.