Table customization not honored in iOS

Part 1
There is an option on table views to Customize the fields that are shown. This field is available on the Web and iPadOS clients, but not the iOS client.

Part 2
Even though the iOS client does not show this option for some reason, it is also not honoring the settings made in the other clients. For example, if I hide a column in the web client, this is carried through to the iPadOS client. However, the iOS client still shows the hidden field.

Maybe space for the option is an issue in iOS, but that does not mean that the client should not apply the setting as defined in the other clients.

Hey @mike.shappell,

Welcome to the Community Forum!

The thing is our mobile applications are much simpler and do not support all the features we have in the web version.

If we’ve included all the features from web version, mobile would be too complicated to use + the interface would be overwhelmed/cluttered.

We’re thinking of improving this of course, as the resources and time allow us that.

I think you are arguing for this particular fix. I have hidden a column in the app, therefore it should not be shown. Especially on iOS where we have the least amount of space. Showing a field that is hidden by definition is cluttering the interface/view with unnecessary/unwanted information.

I am not asking for you to add the customization option to the iOS interface, rather, I am asking that the interface not show things that are hidden. Showing something that should not be visible is a bug, in my opinion. In fact, the web interface on iOS shows the hidden field, just like the app when in portrait mode, but not in landscape. However, landscape is not an option for the iOS app for some reason.

BTW, I have found a number of other bugs, but apparently being new I cannot add more topics today :slight_smile:

UPDATE: I have verified that the web application exhibits the same behavior when the width of the view is reduced to the point that it switches to the smaller (portrait) width constrained view. So like the iOS app, the web app also displays content that should be hidden.


Thanks @mike.shappell for the clarification.

I’ll definitely report this to the team in order for this to be resolved ASAP.

Feel free to report more bugs either here, replying to these topics (you don’t have to start a new one for each). Or contact Boka on our website (Intercom button in the bottom right corner).

1 Like