Tedious login problems

#1

If I close my computer and restart,
my browser is set to remember my tabs, not my cookies.
When I click on a tab for an infinity board, it shows a password window for that board.

It needs an option to sign in with the main infinity password as well and load that specific board in that specific tab. Once signed in the other tabs will work, it’s just the 1st tab, I try that generates this problem.

Currently, if you put in your infinity password it rejects it as it is expecting a board password, I am not even sure if one was ever set.

Then the workflow becomes tedious.

1 - navigate away from your board tab to the main start infinity web address.
2 - click on the login menu on the top nav.
3 - look at the overview of all your boards and click again on the board you want, wait for it to load.

Sorry guys this is way too many clicks when the original board form should have recognised the master password or had a separate option to log in to that board with a master password.

0 Likes

#2

Hey @Derrick sorry for the late reply on this.

Usually, if you have your browser set up that way (remember cookies), it will immediately open all your tabs and open the boards you are logged into without any issues.

However, if you’ve set it up differently, then the situation changes.

According to your screenshot, it looks like this is a public board and it has password protection. Since you’ve set up your browser to log you out, then Infinity sees you as a ‘guest’ on this public board and immediately asks for a password.

If the board is not public, the tab should redirect you to Infinity’s login page and then after you log in, it will redirect you to the board where you originally were. I just tested this using incognito mode and it worked perfectly for me.

So the only issue here is with the public boards, but to be honest, I’m not sure if this can be done any differently on our side because, with the settings you have, the browser goes to the public board link and automatically detects you as being a guest since you’re not logged in. It doesn’t redirect you to the login page because it’s a public link/board.

Hope that makes sense. Let me know if I got something wrong here or misunderstood you somehow.

0 Likes

#3

@Jovana
This is simply solved by having a toggle on the guest box, saying something like, are you the owner, log into account here…

In the meantime I have changed my setup so this doesn’t happen to me. Though it will still affect anyone with that setup.
My aim in reporting this was to give you guys real user experience, which hopefully will help you in improving your product.

1 Like